The Version/Release Swimlane option is not available

Symptom

You may find on some story maps, that the version swimlane option is not available. 

Causes

There are three ways this can occur.

1. Your agile board spans multiple projects

If the (scrum or kanban) agile board's filter you're using to create your story map contains more than one project, the Versions swimlane option is disabled.

Dragging an issue from one version to another in the same project only requires us to change the fixVersions field's value. However, since Versions are project-specific, to move an issue from a version in one project to a version in another project would require us to move the issue to the project of the new version. Due to field configurations being different between projects, this is not something we can do reliably via the REST api.  

2. The Fix Version field not present on the project screens

When the fixVersion field is not on the screen for the issues it is not accessible by Easy Agile User Story Maps. Some teams (mostly doing SaaS deployments) don't have a need for a version field, so the versions swimlanes make no sense to them.

To add the Fix Version field:

  1. Click Project Settings in the project sidebar
  2. Select the Screens tab
  3. Select the screen associated with the Create & Edit issue operations
  4. Add the Fix Version field

3. The Fix Version field is hidden on the field configuration

When the fixVersion field is hidden on the field configuration for the project/s it is not accessible by Easy Agile User Story Maps. 

To add the Fix Version field:

  1. Click Project Settings in the project sidebar
  2. Select the Fields tab
  3. Select 'Edit fields' from the Actions menu in the top right
  4. Click 'Show' next to the Fix Version field


4. Versions are not supported for Next-Gen Projects

Releases/Versions are not supported in Next-Gen projects by default. As a result, Version swimlanes are disabled for all Next-Gen User Story Maps. 


5. You don't have the Create or Resolve Issue permission

When a user isn't granted the Create Issue or Resolve Issue permission the versions in your project aren't exposed to User Story Maps. This can be resolved by granting the user the Create Issue and Resolve Issue permission.




If this does not solve your issue, please reach out to our Customer Support Team and we will be happy to help!