Issues Missing from Story Map - Status Category Not Mapped

Symptom

Issues you believe should be appearing on the story map are not present.

Cause

Jira provides the ability to create unlimited Statuses. Each Status must be mapped to one of three Status Categories: 'To Do' (blue), 'In Progress' (yellow) or 'Done' (green). If a status is not mapped to one of these three categories we are unable to detect issues associated with it through the API.

Solution

Filtering on the Fix this by setting a Status Category for each status in Jira. Steps can be found in this article from Atlassian.