Issues Missing from Story Map

Symptom

Issues you believe should be appearing on the story map are not present.

Causes

There are numerous potential reasons for issues to be missing from the story map, we have outlined them, and their solutions below. If none of these match your circumstances please reach out to us via the Customer Support Portal.

There are filters enabled that are hiding your issues

Epics and Issues on the Story Map can be filtered by any of the following fields:

  • Components
  • Assignee
  • Quick Filters
  • Status Categories 
  • Persona (if Easy Agile Personas is installed)
  • Importance to Persona (if Easy Agile Personas is installed)


These filters prevent issues that do not meet their conditions from being displayed on the story map.

Solution

These filters can be enabled or disabled under the Filters menu:




Status Category Not Mapped

Jira provides the ability to create unlimited Statuses. Each Status must be mapped to one of three Status Categories: 'To Do' (blue), 'In Progress' (yellow) or 'Done' (green). If a status is not mapped to one of these three categories we are unable to detect issues associated with it through the API.

Solution

Filtering on the Fix this by setting a Status Category for each status in Jira. Steps can be found in this article from Atlassian.

Board Filter Query / Kanban Board sub-filter Query

Each board has a specific board filter query, designed to help teams focus on the work that matters to them. Sometimes these filters include clauses or restrictions that prevent the story map from rendering correctly.

The most common issues are when they exclude:

  • Epics, or other issue types
  • Done issues
  • Unassigned or Assigned issues
  • Labels or Components

Solution

Remove the exclusion clause from the board filter query, instructions on how to do this can be found in this article from Atlassian.